Jump to content
DYU Official Forum

D3+ Won't properly switch off


Recommended Posts

Hi, I got a new D3+ but after the first trip out and charge, it won't switch off.  The throttle and pedal assist stay active when the LCD is switched off, also Bluetooth stays active.

If you leave the screen on, it does go off after 10 minutes, but again throttle, pedal assist and Bluetooth are still active.

Also Bluetooth app appears to be misreporting the battery charge,  its taking 0.44 KWH on my charge meter each time, which allowing for losses would be about 360 watt hours that the battery is, so I believe that the battery is fully charging, however Bluetooth showed 100% at full charge the first day, then after 20KM use 75% and after a further 20KM use 58%, but then after charging it went DOWN to 40%

I then rode it 36KM throttle only, and it went down to 3%, and the LCD only went to 1 bar when the Bluetooth went to 4%.  Fully charged it again and it only went back up to 30% and then dropped to 28% despite being switched "off"   Checked again this afternoon and the throttle and pedal assists are still on despite the LCD being off.

Really shouldn't do that for a new bike.

Link to post
Share on other sites
On 10/12/2020 at 10:44 PM, Gordon said:

Hi, I got a new D3+ but after the first trip out and charge, it won't switch off.  The throttle and pedal assist stay active when the LCD is switched off, also Bluetooth stays active.

If you leave the screen on, it does go off after 10 minutes, but again throttle, pedal assist and Bluetooth are still active.

Also Bluetooth app appears to be misreporting the battery charge,  its taking 0.44 KWH on my charge meter each time, which allowing for losses would be about 360 watt hours that the battery is, so I believe that the battery is fully charging, however Bluetooth showed 100% at full charge the first day, then after 20KM use 75% and after a further 20KM use 58%, but then after charging it went DOWN to 40%

I then rode it 36KM throttle only, and it went down to 3%, and the LCD only went to 1 bar when the Bluetooth went to 4%.  Fully charged it again and it only went back up to 30% and then dropped to 28% despite being switched "off"   Checked again this afternoon and the throttle and pedal assists are still on despite the LCD being off.

Really shouldn't do that for a new bike.

Hi Gordon, sorry hearing about it.  

As you say the e-bike is always power-on no matter you turn it off or not.

So the problem is likely in the switch or bluetooth board.

You need to disassemble the e-bike shell to find the Bluetooth board, unplug the 4 wire terminals on the Bluetooth board, those 4 wires are the switch line.
If it can be turned off after unplugging, then the switch is broken; if it can’t be turned off, the Bluetooth board is broken and you need a replacement.
 

 

 

Link to post
Share on other sites

Removing the Bluetooth board, the screen goes off (as before) but the pedal assist and throttle still are active even though the screen is off.

How can it be the Bluetooth board if the issue happens when it's not connected, or does the Bluetooth actually determine actually switching it off?

The bike is new, how does it get repaired?

 

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...